T1, E1

T1

El sistema del T-Portador, introducido por Bell System en los Estados Unidos en los años 60, fue el primer sistema acertado que soportó la transmisión de voz digitalizada. La tasa de transmisión original (1,544 Mbps) en la línea T-1 es comúnmente usada hoy en día en conexiones de Proveedores de Servicios de Internet (ISP) hacia la Internet. En otro nivel, una línea T-3, proporciona 44,736 Mbps, que también es comúnmente usada por los Proveedores de Servicios de Internet. Otro servicio comúnmente instalado es un T-1 fraccionado, que es el alquiler de una cierta porción de los 24 canales en una línea T-1, con los otros canales que no se están usando.

El sistema T-portador es enteramente digital, usando código de modulación pulso y multiplexación de división de tiempo. El sistema utiliza cuatro hilos y proporciona la capacidad a dos vías (dos hilos para recibir y dos para enviar en el mismo tiempo). La corriente digital T-1 consiste en 24 canales 64-Kbps multiplexados. (el canal estandar de 64 Kbps se basa en el ancho de banda necesaria para una conversación por voz.) Los cuatro hilos eran originalmente un par de cables de cobre trenzado, pero ahora pueden también incluir cable coaxial, la fibra óptica, la microonda digital, y otros medios. Un número de variaciones en el número y uso de canales es posible.

En el sistema T-1, las señales de la voz se muestrean 8.000 veces por segundo y cada muestra se digitaliza en una palabra de 8-bit. Con 24 canales que son convertidos a digital al mismo tiempo, un marco de 192-bit (24 canales cada uno con una palabra 8-bit) se está transmitiendo así 8.000 veces al segundo. Cada marco es separado del siguiente por un solo bit, haciendo un bloque 193-bit. El marco de 192 bit se multiplicó por 8.000 y los 8.000 bit que enmarcan hacen crecer la tasa de datos del T-1 hasta 1,544 Mbps. Los bits de señalización son los menos significativos para cada marco.

El sistema T1 se usa en EUA,Canada y Japon

E1

E1 es un formato de transmisión digital; su nombre fue dado por la administración de la (CEPT). Es una implementación de la portadora-E.

El formato de la señal E1 lleva datos en una tasa de 2,048 millones de bits por segundo y puede llevar 32 canales de 64 Kbps * cada uno, de los cuales treinta y uno son canales activos simultáneos para voz o datos en SS7 (Sistema de Señalización Número 7). En R2 el canal 16 se usa para señalización por lo que están disponibles 30 canales para voz o datos. E1 lleva en una tasa de datos algo más alta que el T-1 (que lleva 1,544 millones de bits por segundo) porque, a diferencia del T-1, no hace el bit-robbing y los ocho bits por canal se utilizan para cifrar la señal. E1 y el T-1 se pueden interconectar para uso internacional.

Un enlace E1 opera sobre dos juegos separados de cable, usualmente es un cable coaxial. Una señal nominal de 2.4 voltios es codificada con pulsos usando un método que evita períodos largos sin cambios de polaridad. La taza de línea es de 2.048 Mbit/s (full duplex, ej. 2.048 Mbit/s descarga y 2.048 Mbit/s carga) el cual esta abierto en 32 segmentos de tiempo (llamados Time Slots), cada uno tiene un turno direccionado de 8 bit. De esa manera cada casilla envía y recibe un número de 8 bits muestreado 8000 veces por segundo(8 x 8000 x 32 = 2,048,000). Esto es ideal para llamadas telefónicas de voz, en donde la voz es muestreada en un número de 8 bit y esa taza de datos es reconstruida en el otro extremo.

Una casilla de tiempo (TS0) es reservado para efectos de segmentación, y transmite alternadamente un patrón arreglado. Esto permite al receptor detectar el inicio de cada trama y encontrar cada canal en el turno. Los estandares permiten que se realice un chequeo de redundacia cíclica a través de todos los bit transmitidos en cada segmento, para detectar si el circuito está perdiendo bits (información), pero esto no siempre es usado.

Una casilla de tiempo (TS16) es usualmente reservada para propósitos de señalización, para controlar la configuración de la llamada y desmonte de acuerdo a varios protocolos estandar de telecomunicaciones. Esto incluye señalización de canales asociados (Channel Associated Signaling – CAS) en donde un juego de bits es usado para replicar la apertura y cerrada del circuito (como si se descolgara y se marcara en un teléfono analógico). Sistemas más recientes usan señalización de canal común (Common Channel Signaling – CCS)como ISDN o sistema de señalización número 7 (SS7 – Signalling System 7) el cual envía pequeños mensajes codificados con más información de la llamada, incluyendo Identificador de llamada (Caller ID), tipo de transmisión requerida etc. ISDN es usado normalmente entre nodos locales de telefonía y negocios principales, mientras que SS7 es casi exclusivamente usado entre nodos y operadores. SS7 puede manejar hasta 4096 circuitos por canal de señalizacion, de esa manera es levemente más eficiente en el uso total de la transmisión del ancho de banda.

A diferencia de los anteriores sistemas T-carrier desarrollados en Norteamerica, todos los 8 bits de cada muestreo están disponibles en cada llamada. Esto permite el sistema E1 ser usado igualmente bien para circuitos de llamadas de datos, sin riesgos de pérdidas de información.

Mientras que el estandar CEPT G703 especifica muchas opciones para la transmisión fisica, se utiliza de forma casi exclusiva el formato HDB3.

El E1 se usa en todo el mundo excepto Canada, Estados Unidos y Japon

Configuración de FRAME-RELAY en Router Cisco

Configuración de FRAME-RELAY en Router Cisco

Frame Relay o (Frame-mode Bearer Service) es una técnica de comunicación mediante retransmisión de tramas para redes de circuito virtual, introducida por la ITU-T a partir de la recomendación I.122 de 1988. Consiste en una forma simplificada de tecnología de conmutación de paquetes que transmite una variedad de tamaños de tramas o marcos (“frames”) para datos, perfecto para la transmisión de grandes cantidades de datos.

La técnica Frame Relay se utiliza para un servicio de transmisión de voz y datos a alta velocidad que permite la interconexión de redes de área local separadas geográficamente a un coste menor.

Frame Relay proporciona conexiones entre usuarios a través de una red pública, del mismo modo que lo haría una red privada punto a punto, esto quiere decir que es orientado a la conexión.

Las conexiones pueden ser del tipo permanente, (PVC, Permanent Virtual Circuit) o conmutadas (SVC, Switched Virtual Circuit). Por ahora sólo se utiliza la permanente. De hecho, su gran ventaja es la de reemplazar las líneas privadas por un sólo enlace a la red

Entrando en configuración de equipos.

Lo ideal a la hora de realizar una configuración de FRAME RELAY es ya tener a la mano los DLCI para los enlaces hacia tus destinos remotos, el DLCI no es mas que el identificador de la interfaz que el proveedor del servicio FR te otorga para que sea configurada en el ROUTER, para entenderlo de otra manera, es el numero de circuito ya habilitado para que un equipo tenga acceso a otro a traves de la Red del proveedor.
A continuación se muestra un ejemplo bien practico y sencillo para entender la configuración:

interface Serial0/0/0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0/0/0.100 point-to-point
description DLCI 100 (Hacia GUARICO)
ip address 200.150.100.1 255.255.255.252
frame-relay interface-dlci 100
!
interface Serial0/0/0.110 point-to-point
description DLCI 110 (Hacia AMAZONAS)
ip address 200.150.120.1 255.255.255.252
frame-relay interface-dlci 110
!
interface Serial0/0/0.120 point-to-point
description DLCI 120 (Hacia Nva. Esparta)
ip address 200.150.130.1 255.255.255.252
frame-relay interface-dlci 120
!
interface Serial0/0/0.130 point-to-point
description DLCI 130 (Hacia Miranda)
ip address 200.150.140.1 255.255.255.252
frame-relay interface-dlci 130

En las Interfaz Virtuales se configura a traves de la IP ADDRESS y el numero de DLCI, el acceso Punto a Punto previamente declarado en la interfaz fisica.
En la interfaz fisica ya se debe tener configurado el tipo de encapsulation y de LMI , que se refiere al tipo de paquete que va a manejar el Frame Relay.

En este ejemplo el router de CARACAS posee 4 enlaces Punto a Punto con 4 estados (GUARICO, AMAZONAS, NVA.ESPARTA Y MIRANDA) todos los estados se conectan a el a traves del Frame Realay que el Proveedor de Servicio configura en sus terminales para crear los DLCI, el ingeniero en redes dese ser capaz de interpretar cuales son sus enlaces y las interfaces asociadas a cada interfaz para conocer el flujo y trafico de datos.

Puertos TCP y UDP

21 TCP FTP
21 UDP FTP
22 TCP SSH
22 UDP SSH
23 TCP Telnet
23 UDP Telnet
25 TCP SMTP
25 UDP SMTP
66 TCP Oracle SQLNet
66 UDP Oracle SQLNet
79 TCP Finger
79 UDP Finger
80 TCP HTTP – Web Aliens vs. Predator
80 UDP HTTP – Web
107 TCP Remote Telnet Service
107 UDP Remote Telnet Service
110 TCP POP3
110 UDP POP3
118 TCP SQL Services
118 UDP SQL Services
119 TCP NNTP – Grupos de Noticias
119 UDP NNTP – Grupos de Noticias
137 TCP NetBios Name Service
137 UDP NetBios Name Service
138 TCP NetBios Datagram Service
138 UDP NetBios Datagram Service
139 TCP NetBios Session Service
139 UDP NetBios Session Service
150 TCP SQL-Net
150 UDP SQL-Net
161 TCP Snmp
194 TCP Internet Relay Chat
194 UDP Internet Relay Chat
209 TCP Quick Mail Protocol
209 UDP Quick Mail Protocol
217 TCP dBASE Unix
217 UDP dBASE Unix
389 TCP NetMeeting
407 TCP Timbuktu pro
407 UDP Timbuktu pro
443 TCP HttpS
445 TCP Microsoft-Ds (compartir archivos en win 2000)
515 TCP printer
522 TCP NetMeeting
531 TCP Conference
531 UDP Conference
568 TCP Microsoft Shuttle
568 UDP Microsoft Shuttle
569 TCP Microsoft Rome
569 UDP Microsoft Rome
666 TCP doom ID Software
666 UDP doom ID Software
700 UDP Buddy Phone
701 UDP Buddy Phone
992 TCP Telnet SSL
992 UDP Telnet SSL
993 TCP IMAP4 SSL
993 UDP IMAP4 SSL
995 TCP POP3 SSL
995 UDP POP3 SSl
1024 – 5000 TCP Dwyco Video Conferencing
1414 UDP CuSeeMe
1417 TCP Timbuktu pro
1417 UDP Timbuktu pro
1418 TCP Timbuktu pro
1418 UDP Timbuktu pro
1419 TCP Timbuktu pro
1419 UDP Timbuktu pro
1420 TCP Timbuktu pro
1420 UDP Timbuktu pro
1424 UDP CuSeeMe
1503 TCP NetMeeting CuSeeMe
1547 TCP LapLink
1720 TCP NetMeeting CuSeeMe
1731 TCP NetMeeting
1812 UDP CuSeeMe
1813 UDP CuSeeMe
2300 TCP Everquest
2300 UDP Everquest Age of Empires
2300 – 2400 TCP Battlecom
2300 – 2400 UDP Battlecom Aliens vs. Predator
2301 TCP Age of Empires
2301 UDP Age of Empires
2302 TCP Age of Empires
2302 UDP Age of Empires
2303 TCP Age of Empires
2303 UDP Age of Empires
2304 TCP Age of Empires
2304 UDP Age of Empires
2305 TCP Age of Empires
2305 UDP Age of Empires
2306 TCP Age of Empires
2306 UDP Age of Empires
2307 TCP Age of Empires
2307 UDP Age of Empires
2308 TCP Age of Empires
2308 UDP Age of Empires
2309 TCP Age of Empires
2309 UDP Age of Empires
2310 TCP Age of Empires
2310 UDP Age of Empires
2311 TCP Age of Empires
2311 UDP Age of Empires
2400 TCP Everquest Age of Empires
2611 TCP Black and White
2612 TCP Black and White
3000 TCP Active Worlds
3000 UDP Calista IP phone (saliente)
3100-3999 TCP Delta Force
3100-3999 UDP Delta Force
3128 TCP Squid Proxy
2301 TCP Age of Empires
3389 TCP Windows 2000 Terminal Server
3389 UDP Windows 2000 Terminal Server
3568 UDP Delta Force 2
3569 UDP Delta Force 2
4000 TCP Diablo II ICQ
4099 TCP AIM Talk
4661 TCP Edonkey 2000
4662 TCP Edonkey 2000 Overnet
4662 UDP Overnet
4665 UDP Edonkey 2000
5190 TCP Calista IP phone (entrante)
5500 TCP Virtual Network Computing
3568 UDP Delta Force
5631 TCP pcAnyWhere (host)
5632 UDP pcAnyWhere (host)
5670 TCP Active Worlds
**:: edit spam sms ::** TCP Virtual Network Computing
5900 TCP Virtual Network Computing
6003 UDP Half Life
6112 TCP Diablo II
6112 UDP Diablo II
6112 TCP StarCraft
6112 UDP StarCraft
6257 UDP WinMX
6346 TCP SwapNut
6346 UDP SwapNut
6500 TCP Black and White
6667 TCP Ircd Black and White MSN Game Zone
6699 TCP WinMX
6700 – 6702 TCP Dwyco Video Conferencing
6880 TCP Dwyco Video Conferencin
6891 TCP MSN Messenger (archivos)
6892 TCP MSN Messenger (archivos)
6893 TCP MSN Messenger (archivos)
6894 TCP MSN Messenger (archivos)
6895 TCP MSN Messenger (archivos)
6896 TCP MSN Messenger (archivos)
6897 TCP MSN Messenger (archivos)
6898 TCP MSN Messenger (archivos)
6899 TCP MSN Messenger (archivos)
6900 TCP MSN Messenger (archivos)
6901 TCP MSN Messenger (voz)
6901 TCP MSN Messenger (voz)
7000-7100 TCP Active Worlds
7002 UDP Half Life
7013 TCP Anarchy Online
7013 UDP Anarchy Online
7500 – 7501 TCP Anarchy Online
7500 – 7501 UDP Anarchy Online
7640 TCP CuSeeMe
7642 TCP CuSeeMe
7648 UDP CuSeeMe
7648 TCP CuSeeMe
7649 TCP CuSeeMe
7777 UDP Unreal Tournament (cliente) Active Worlds
7778 UDP Unreal Tournament (servidor)
7779 UDP Unreal Tournament
7780 UDP Unreal Tournament
7781 UDP Unreal Tournament
8000 – 8999 UDP Aliens vs. Predator
8080 TCP Unreal Tournament (UT Server Admin) HTTP Proxy
9000 UDP Asheron’s Call
9004 UDP Asheron’s Call
9005 UDP Asheron’s Call
9008 UDP Asheron’s Call
9012 UDP Asheron’s Call
9013 UDP Asheron’s Call
12000 – 16090 UDP Dwyco Video Conferencing
12053 TCP Delta Three PC to Phone
12083 TCP Delta Three PC to Phone
12080 UDP Delta Three PC to Phone
12120 UDP Delta Three PC to Phone
12122 UDP Delta Three PC to Phone
20000-20019 TCP ICQ
24150 – 24179 UDP Delta Three PC to Phone
26000 UDP Elite Force
26214 TCP Dark Reign 2
26214 UDP Dark Reign 2
27015 UDP COUNTER STRIKE
27500 UDP Unreal Tournament (uplink) Elite Force
27660 UDP Quake III (primer jugador)
27661 UDP Quake III (segundo jugador)
27662 UDP Quake III (tercer jugador)…
27900 UDP Unreal Tournament (uplink) Black and White
27910 UDP Elite Force
27960 UDP Elite Force
28800 – 29000 TCP MSN Game Zone
47624 TCP Battlecom
47624 UDP Battlecom
56800 UDP CuSeeMe

Configuracion de RIP, EIGRP, OSPF

CONFIGURAR PROTOCOLO DE ENRUTAMIENTO RIP

RCARACAS#CONFIG TERMINAL
RCARACAS(config)#ROUTER RIP
RCARACAS(config-router)#

“Inmediatamente dentro de la configuración del protocolo RIP, agregamos con el comando network las redes que tenemos directamente conectadas al router y que queremos que el comparta la información a los router vecinos, es decir, lo que estan directamente conectados a él”

network 10.0.0.0
network 12.0.0.0
network 13.0.0.0
network 15.0.0.0
network 192.168.9.0
network 192.168.10.0

Luego de esto… para verificar que el protocolo quedo bien configurado , lo necesario es hacer un debug del proceso donde se podrá observar a tiempo real las redes recibidas y enviadas en el momento. El comando es el Siguiente:

RCARACAS#debug ip rip
RIP protocol debugging is on
RCARACAS#RIP: received v1 update from 13.0.0.1 on Serial0/1/1

14.0.0.0 in 1 hops

16.0.0.0 in 1 hops

17.0.0.0 in 2 hops

18.0.0.0 in 2 hops

30.0.0.0 in 2 hops

31.0.0.0 in 2 hops

172.17.0.0 in 2 hops

“Actualizaciones desde el equipo 13.0.0.1 recibida por la serial0/1/1 de router RCARACAS”
desactivas el debug:


RCARACAS#undebug ip rip
RIP protocol debugging is off

CONFIGURAR PROTOCOLO DE ENRUTAMIENTO EIGRP

RCARACAS#CONFIG TERMINAL
RCARACAS(config)#ROUTER EIGRP
RCARACAS(config-router)#

“Inmediatamente dentro de la configuración del protocolo EIGRP, agregamos con el comando network las redes que tenemos directamente conectadas al router y que queremos que el comparta la información a los router vecinos, es decir, lo que estan directamente conectados a él, seguidos de la mascara WILDCARD, que no es mas que la mascara de subred, al reves, es decir, los octetos que son 255-son 0 y los que son 0-son 255”

network 20.0.0.0 0.0.0.255
network 21.0.0.0 0.0.0.255
network 23.0.0.0 0.0.0.255
network 195.168.2.0 0.0.0.255

CONFIGURAR PROTOCOLO DE ENRUTAMIENTO OSPF

RCARACAS#CONFIG TERMINAL
RCARACAS(config)#ROUTER OSPF # Process ID
RCARACAS(config-router)#

“Inmediatamente dentro de la configuración del protocolo OSPF, agregamos con el comando network las redes que tenemos directamente conectadas al router y que queremos que el comparta la información a los router vecinos, es decir, lo que estan directamente conectados a él, seguidos de la mascara WILDCARD, que no es mas que la mascara de subred, al reves, es decir, los octetos que son 255-son 0 y los que son 0-son 255 y el area que conforma ese ambiente (en mi caso es el 0)”


network 20.0.0.0 0.0.0.255 area 0
network 21.0.0.0 0.0.0.255 area 0
network 23.0.0.0 0.0.0.255 area 0
network 195.168.2.0 0.0.0.255 area 0

“Actualizaciones y eventos del protocolos OSPF del router RCARACAS”
desactivas el debug:

RMIRANDA#debug ip ospf events
00:28:22: OSPF: Rcv hello from 193.168.2.1 area 0 from Serial0/0/0 23.0.0.1

00:28:22: OSPF: End of hello processing

00:28:27: OSPF: Rcv hello from 194.168.2.1 area 0 from Serial0/1/1 21.0.0.2

00:28:27: OSPF: End of hello processing

00:28:32: OSPF: Rcv hello from 193.168.2.1 area 0 from Serial0/0/0 23.0.0.1

00:28:32: OSPF: End of hello processing

Instalación y Configuración de TACACS+

Introduccion

Un servidor TACACS provee una ubicacion centralizada AAA (Authentication, Authorization y Accounting) para dispositivos Cisco. La Autentificacion de los usuarios se puede realizar de 2 maneras; con la base de datos local del dispositivo o con el servidor TACACS. El modelo TACACS provee funcionalidades adicionales tales como la autorizacion de comandos especificos segun el usuario, ademas de un registro historico detallado de los accesos a los dispositivos y los comandos ejecutados.

La presente informacion describe el proceso de instalacion y configuracion de un servidor TACACS+ (tac-plus) en Linux Debian y tambien algunos de los comandos que se deben configurar en los dispositivos Cisco a traves de su IOS.
Lee el resto de esta entrada